Passa ai contenuti principali

MIME

Il mio notebook Evernote "Internet" contiene link a siti web che permettono di fare conversioni da/a base64 e quoted-printable. In particolare:
Non garantisco della loro correttezza. Possono essere interessanti per avere rapidamente un'idea di cosa accade nella realtà.

Uno di voi ha approfondito personalmente alcuni aspetti di MIME, riporto di seguito le sue riflessioni a beneficio di tutti.

ATTENZIONE: non garantisco della correttezza di queste riflessioni e non ho il tempo di renderle più chiare (secondo me se uno non ha già le idee chiare ci capisce poco). Le riporto per incoraggiarvi a "partecipare"...


Premetto che le lettere accentate (come ha detto Lei) non riguardano i primi 128 character codes del US-ASCII. Quindi ho cercato di sanare la mia curiosità e condivido quanto raccolto. 
 
Dato per assodato il vincolo imposto dal protocollo SMTP (bit 8 = 0).
Domanda perché non usare per l’EncodingType tutti i 128 caratteri del US-ASCII invece di 64 visto che:
-        in base64, 3 Byte vengono codificati in 4 Byte con dimensione finale ~= 133%;
-        in base128, 7 Byte vengono codificati in 8 Byte con dimensione finale ~= 114%, quindi più efficiente!

Risposta dando un’occhiata alle RFC 1421, 1521 e 2045, che grossomodo dicono le stesse cose.
Il perché in base64 e non base128 si spiega osservando che è necessario:
-        avere una rappresentazione stampabile del carattere per evitare gli “ASCII control characters” che vanno da 0-31 ed il 127 e che possono avere comportamenti diversi in sistemi diversi (, );
-        non utilizzare caratteri che possono avere un significato nella comunicazione o per il sistema ospitante (p.e.: ~ , . ).
-        ammesso che, in deroga a quanto sopra scritto, fosse stato possibile usare 7 bit per la transcodifica, non ci sarebbe stata la possibilità di trasmettere in SMTP il “padding character (=)” che richiede un bit in più per distinguersi dalle sequenze binarie già usate.

Riferito all’aspetto 1

RFC 1421: “ Although SMTP specifies a standard representation for line delimiters (ASCII ), numerous systems in the Internet use a different native representation to delimit lines.  For example, the sequences delimiting lines in mail inbound to UNIX systems are transformed to single s as mail is written into local mailbox files.  Lines in mail incoming to record-oriented systems (such as VAX VMS) may be converted to appropriate records by the destination SMTP server”

Riferito all’aspetto 2

RFC 2045: “These characters, identified in Table 1, below, are selected so as to be universally representable, and the set excludes characters with particular significance to SMTP (e.g., ".", CR, LF) and to the multipart boundary delimiters defined in RFC 2046 (e.g., "-").”
 

Commenti

Popular Posts

"Ingegneria deve essere difficile"

Il ritaglio di giornale qui sotto ricorda uno degli eventi più non-trovo-un-aggettivo-appropriato del mio periodo di studente di Ingegneria a Pisa. Ricordo che una mattina iniziò a spargersi la voce "hanno murato la porta del dipartimento!".  Andammo subito a vedere ed arrivammo un pò prima dei giornalisti che scattarono questa foto. La porta era murata, intonacata, pitturata di bianco e sovrastata da una scritta "INGEGNERIA DEVE ESSERE DIFFICILE". Le "E" di "INGEGNERIA" erano scritte al contrario perché era una sorta di "marchio di fabbrica" della facoltà di Ingegneria di Pisa. L'aula più grande, quella in cui pressoché tutti gli studenti seguivano i corsi dei primi anni, aveva infatti alcuni bellissimi "affreschi scherzosi" che furono fatti nel corso delle proteste studentesche di qualche anno prima ed in cui la parola "Ingegneria" era appuntoi scritta in quel modo. Si era anche già sparsa la voce di cosa era ...

On the Anthropic Mythos Preview - "too dangerous to release"

(updated twice after first posting, see below) On April 7-th 2026, Anthropic issued a technical report titled  Assessing Claude Mythos Preview’s cybersecurity capabilities . This report has quickly sparked the all-too-common (and deeply misleading) narrative of an imminent cybersecurity apocalypse due to the (supposedly) immense and groundbreaking capabilities of AI. For example, The New York Times :  I’m really not being hyperbolic when I say that kids could deploy this by accident. Mom and Dad, get ready for: "Honey, what did you do after school today?” “Well, Mom, my friends and I took down the power grid. What’s for dinner?” That is why Anthropic is giving carefully controlled versions to key software providers so they can find and fix the vulnerabilities before the bad guys do — or your kids. What does Anthropic say? The following paragraphs contain a slightly edited AI-generated summary of the Anthropic report Anthropic has introduced Claude Mythos Preview, a langu...

Perché studiare Analisi Matematica???

Un mio caro amico mi ha scritto: ...sono con mia figlia che studia Analisi 1...A cosa serve, al giorno d'oggi, studiare Analisi (a parte sfoltire i ranghi degli aspiranti ingegneri)? Riporto la mia risposta di seguito, forse può "motivare" qualche altro studente. ... Per un ingegnere la matematica è fondamentale perché è un linguaggio ; ed è il linguaggio essenziale per trattare gli argomenti che dovrà affrontare come ingegnere; non sono importanti i contenuti specifici; è importante, anzi fondamentale, che riesca a capirli, ricostruirli etc. ad esempio, chi deve usare l'inglese, lo usa perché in un modo o nell'altro lo conosce; nessuno di noi ha usato esattamente le frasi o i dialoghi o le regole che ha incontrato negli esercizi di inglese o di tedesco; nella matematica è lo stesso; non sono importanti i limiti, le serie, i teoremi di cauchy o che so io; ma se uno non è in grado di capire quel linguaggio allora non sarà in grado di capire davvero quas...

More detailed assessment of Anthropic Mythos Preview

A follow-up to my previous post on Mythos Preview. The AI Security Institute (AISI) has published a very interesting analysis of Mythos Preview . Very interesting because: AISI is " a mission-driven research organisation in the heart of the UK government ". Its reports are clearly much more credible than claims of the form " our last product is too strong to give you, believe us " by a private US company, that is currently losing lot of money, that is fiercely battling against other  companies in the AI arena, that is extremely good at fuelling hype about their products and capabilities. They consider complete cybersecurity tasks, i.e. CTF (capture the flag) competitions and attacks to a simulated organization. They compare the behavior of different models for a given "token budget". Not surprisingly, Mythos Preview is indeed very good and better than previous models, but it is definitely not the coming Apocalipsis. In particular, it is the first tool th...

Anthropic Mythos - from the inside

 An excerpt from a blog post by one of the maintainers of curl . A person with a lot of "real world experience" on one of the most widely used software tools in the planet. Everything in the bulleted list below has been just copied-and-pasted (bold is mine, it was not in the original post). I have not added any comment, it is not necessary. This analysis goes in exactly the same direction that I hypothesized in my previous posts ( here and here ). Before this first Mythos report, we had already scanned curl with several different very capable AI powered tools (I mean in addition to running a number of “normal” static code analyzers all the time, using the pickiest compiler options and doing fuzzing on it for years etc)... These tools and the analyses they have done have triggered somewhere between two and three hundred bugfixes merged in curl through-out the recent 8-10 months or so. A bunch of the findings these AI tools reported were confirmed vulnerabilities and have b...